#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\.)((^|\.)([1-9]?\d|1\d\d|2(5[0-5]|[0-4]\d))){4}$"
Local $sString = "115.42.150.37" & @CRLF & _
"192.168.0.1" & @CRLF & _
"110.234.52.124" & @CRLF & _
"" & @CRLF & _
"01.01.01.01" & @CRLF & _
"1.1.1.01" & @CRLF & _
"123123123213" & @CRLF & _
"210.110" & @CRLF & _
"255" & @CRLF & _
"y.y.y.y" & @CRLF & _
"255.0.0.y" & @CRLF & _
"666.10.10.20" & @CRLF & _
"4444.11.11.11" & @CRLF & _
"33.3333.33.3" & @CRLF & _
"365.1.1.1" & @CRLF & _
"123.123.123.123.123" & @CRLF & _
".123.123.123.123" & @CRLF & _
"123.123.123.123." & @CRLF & _
"1.2.3.256" & @CRLF & _
"1.2.260.1" & @CRLF & _
"1.333.1.1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")