use strict;
my $str = '115.42.150.37
192.168.0.1
110.234.52.124
01.01.01.01
1.1.1.01
123123123213
210.110
255
y.y.y.y
255.0.0.y
666.10.10.20
4444.11.11.11
33.3333.33.3
365.1.1.1
123.123.123.123.123
.123.123.123.123
123.123.123.123.
1.2.3.256
1.2.260.1
1.333.1.1
';
my $regex = qr/^(?!\.)((^|\.)([1-9]?\d|1\d\d|2(5[0-5]|[0-4]\d))){4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}