re = /^(?!\.)((^|\.)([1-9]?\d|1\d\d|2(5[0-5]|[0-4]\d))){4}$/m
str = '115.42.150.37
192.168.0.1
110.234.52.124
01.01.01.01
1.1.1.01
123123123213
210.110
255
y.y.y.y
255.0.0.y
666.10.10.20
4444.11.11.11
33.3333.33.3
365.1.1.1
123.123.123.123.123
.123.123.123.123
123.123.123.123.
1.2.3.256
1.2.260.1
1.333.1.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end