const regex = /^(?!\.)((^|\.)([1-9]?\d|1\d\d|2(5[0-5]|[0-4]\d))){4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\.)((^|\\.)([1-9]?\\d|1\\d\\d|2(5[0-5]|[0-4]\\d))){4}$', 'gm')
const str = `115.42.150.37
192.168.0.1
110.234.52.124
01.01.01.01
1.1.1.01
123123123213
210.110
255
y.y.y.y
255.0.0.y
666.10.10.20
4444.11.11.11
33.3333.33.3
365.1.1.1
123.123.123.123.123
.123.123.123.123
123.123.123.123.
1.2.3.256
1.2.260.1
1.333.1.1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}