using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?!Block\d|Field001|Field002|Field_003)[-\w]+"":[^,\r\n]+,?\s*";
string input = @" {
""Block1"":{
""Field001"":""Value001"",
""Field002"":""Value002 "",
""Field003"":1000,
""Field004"":""Value004"",
""Field005"":1000,
""Field00N"":1000
},
""Block2"":{
""Field-001"":""Value-001"",
""Field-002"":""Value-002"",
""Field-003"":""Value-003"",
""Field-00N"":""Value-004""
},
""Block3"":{
""Field_001"":""Value_001"",
""Field_002"":""Value_002"",
""Field_003"":""Value_003""
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}