# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(?!Block\d|Field001|Field002|Field_003)[-\w]+\":[^,\r\n]+,?\s*"
test_str = (" { \n"
" \"Block1\":{ \n"
" \"Field001\":\"Value001\",\n"
" \"Field002\":\"Value002 \",\n"
" \"Field003\":1000,\n"
" \"Field004\":\"Value004\",\n"
" \"Field005\":1000,\n"
" \"Field00N\":1000\n"
" },\n"
" \"Block2\":{ \n"
" \"Field-001\":\"Value-001\",\n"
" \"Field-002\":\"Value-002\",\n"
" \"Field-003\":\"Value-003\",\n"
" \"Field-00N\":\"Value-004\"\n"
" },\n"
" \"Block3\":{ \n"
" \"Field_001\":\"Value_001\",\n"
" \"Field_002\":\"Value_002\",\n"
" \"Field_003\":\"Value_003\"\n"
" }\n"
" }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.