$re = '/"(?!Block\d|Field001|Field002|Field_003)[-\w]+":[^,\r\n]+,?\s*/m';
$str = ' {
"Block1":{
"Field001":"Value001",
"Field002":"Value002 ",
"Field003":1000,
"Field004":"Value004",
"Field005":1000,
"Field00N":1000
},
"Block2":{
"Field-001":"Value-001",
"Field-002":"Value-002",
"Field-003":"Value-003",
"Field-00N":"Value-004"
},
"Block3":{
"Field_001":"Value_001",
"Field_002":"Value_002",
"Field_003":"Value_003"
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);