import Foundation
let pattern = #""(?!Block\d|Field001|Field002|Field_003)[-\w]+":[^,\r\n]+,?\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"Block1":{
"Field001":"Value001",
"Field002":"Value002 ",
"Field003":1000,
"Field004":"Value004",
"Field005":1000,
"Field00N":1000
},
"Block2":{
"Field-001":"Value-001",
"Field-002":"Value-002",
"Field-003":"Value-003",
"Field-00N":"Value-004"
},
"Block3":{
"Field_001":"Value_001",
"Field_002":"Value_002",
"Field_003":"Value_003"
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)