use strict;
my $str = ' {
"Block1":{
"Field001":"Value001",
"Field002":"Value002 ",
"Field003":1000,
"Field004":"Value004",
"Field005":1000,
"Field00N":1000
},
"Block2":{
"Field-001":"Value-001",
"Field-002":"Value-002",
"Field-003":"Value-003",
"Field-00N":"Value-004"
},
"Block3":{
"Field_001":"Value_001",
"Field_002":"Value_002",
"Field_003":"Value_003"
}
}';
my $regex = qr/"(?!Block\d|Field001|Field002|Field_003)[-\w]+":[^,\r\n]+,?\s*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}