import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?!Block\\d|Field001|Field002|Field_003)[-\\w]+\":[^,\\r\\n]+,?\\s*";
final String string = " { \n"
+ " \"Block1\":{ \n"
+ " \"Field001\":\"Value001\",\n"
+ " \"Field002\":\"Value002 \",\n"
+ " \"Field003\":1000,\n"
+ " \"Field004\":\"Value004\",\n"
+ " \"Field005\":1000,\n"
+ " \"Field00N\":1000\n"
+ " },\n"
+ " \"Block2\":{ \n"
+ " \"Field-001\":\"Value-001\",\n"
+ " \"Field-002\":\"Value-002\",\n"
+ " \"Field-003\":\"Value-003\",\n"
+ " \"Field-00N\":\"Value-004\"\n"
+ " },\n"
+ " \"Block3\":{ \n"
+ " \"Field_001\":\"Value_001\",\n"
+ " \"Field_002\":\"Value_002\",\n"
+ " \"Field_003\":\"Value_003\"\n"
+ " }\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}