using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(\[\w{3}=\')(\w+\.\w+)(\'\])(.*?)(\[\w{3}=\')(\w+\.\w+).*";
string substitution = @"$1 <object data=\""https://myurl.com/media/$3\"" class=\""pdf-shortcode-iframe"" type=\""application/pdf\""> <iframe class=\""pdf-shortcode-iframe\"" src=\""https://docs.google.com/viewer?url=https://myurl.com/media/$3&embedded=true\""></iframe> </object>$5 <object data=\""https://myurl.com/media/$7\"" class=\""pdf-shortcode-iframe\"" type=\""application/pdf\""> <iframe class=\""pdf-shortcode-iframe\"" src=\""https://docs.google.com/viewer? url=https://myurl.com/media/$3&embedded=true""></iframe> </object>";
string input = @"Hello, view this pdf [PDF='hello.pdf']
and then view this PDF [PDF='goodmorning.pdf']";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}