# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)(\[\w{3}=\')(\w+\.\w+)(\'\])(.*?)(\[\w{3}=\')(\w+\.\w+).*"
test_str = ("Hello, view this pdf [PDF='hello.pdf'] \n"
"and then view this PDF [PDF='goodmorning.pdf']")
subst = "$1 <object data=\\\"https://myurl.com/media/$3\\\" class=\\\"pdf-shortcode-iframe\" type=\\\"application/pdf\\\"> <iframe class=\\\"pdf-shortcode-iframe\\\" src=\\\"https://docs.google.com/viewer?url=https://myurl.com/media/$3&embedded=true\\\"></iframe> </object>$5 <object data=\\\"https://myurl.com/media/$7\\\" class=\\\"pdf-shortcode-iframe\\\" type=\\\"application/pdf\\\"> <iframe class=\\\"pdf-shortcode-iframe\\\" src=\\\"https://docs.google.com/viewer? url=https://myurl.com/media/$3&embedded=true\"></iframe> </object>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.