const regex = /(.*?)(\[\w{3}=\')(\w+\.\w+)(\'\])(.*?)(\[\w{3}=\')(\w+\.\w+).*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(\\[\\w{3}=\\\')(\\w+\\.\\w+)(\\\'\\])(.*?)(\\[\\w{3}=\\\')(\\w+\\.\\w+).*', 'gs')
const str = `Hello, view this pdf [PDF='hello.pdf']
and then view this PDF [PDF='goodmorning.pdf']`;
const subst = `$1 <object data=\"https://myurl.com/media/$3\" class=\"pdf-shortcode-iframe" type=\"application/pdf\"> <iframe class=\"pdf-shortcode-iframe\" src=\"https://docs.google.com/viewer?url=https://myurl.com/media/$3&embedded=true\"></iframe> </object>$5 <object data=\"https://myurl.com/media/$7\" class=\"pdf-shortcode-iframe\" type=\"application/pdf\"> <iframe class=\"pdf-shortcode-iframe\" src=\"https://docs.google.com/viewer? url=https://myurl.com/media/$3&embedded=true"></iframe> </object>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);