package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(.*?)(\[\w{3}=\')(\w+\.\w+)(\'\])(.*?)(\[\w{3}=\')(\w+\.\w+).*`)
var str = `Hello, view this pdf [PDF='hello.pdf']
and then view this PDF [PDF='goodmorning.pdf']`
var substitution = "$1 <object data=\"https://myurl.com/media/$3\" class=\"pdf-shortcode-iframe" type=\"application/pdf\"> <iframe class=\"pdf-shortcode-iframe\" src=\"https://docs.google.com/viewer?url=https://myurl.com/media/$3&embedded=true\"></iframe> </object>$5 <object data=\"https://myurl.com/media/$7\" class=\"pdf-shortcode-iframe\" type=\"application/pdf\"> <iframe class=\"pdf-shortcode-iframe\" src=\"https://docs.google.com/viewer? url=https://myurl.com/media/$3&embedded=true"></iframe> </object>"
fmt.Println(re.ReplaceAllString(str, substitution))
}