// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(.*?)(\[\w{3}=\')(\w+\.\w+)(\'\])(.*?)(\[\w{3}=\')(\w+\.\w+).*").unwrap();
let string = "Hello, view this pdf [PDF='hello.pdf']
and then view this PDF [PDF='goodmorning.pdf']";
let substitution = "$1 <object data=\\\"https://myurl.com/media/$3\\\" class=\\\"pdf-shortcode-iframe\" type=\\\"application/pdf\\\"> <iframe class=\\\"pdf-shortcode-iframe\\\" src=\\\"https://docs.google.com/viewer?url=https://myurl.com/media/$3&embedded=true\\\"></iframe> </object>$5 <object data=\\\"https://myurl.com/media/$7\\\" class=\\\"pdf-shortcode-iframe\\\" type=\\\"application/pdf\\\"> <iframe class=\\\"pdf-shortcode-iframe\\\" src=\\\"https://docs.google.com/viewer? url=https://myurl.com/media/$3&embedded=true\"></iframe> </object>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}