import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(\\[\\w{3}=\\')(\\w+\\.\\w+)(\\'\\])(.*?)(\\[\\w{3}=\\')(\\w+\\.\\w+).*";
final String string = "Hello, view this pdf [PDF='hello.pdf'] \n"
+ "and then view this PDF [PDF='goodmorning.pdf']";
final String subst = "$1 <object data=\\\"https://myurl.com/media/$3\\\" class=\\\"pdf-shortcode-iframe\" type=\\\"application/pdf\\\"> <iframe class=\\\"pdf-shortcode-iframe\\\" src=\\\"https://docs.google.com/viewer?url=https://myurl.com/media/$3&embedded=true\\\"></iframe> </object>$5 <object data=\\\"https://myurl.com/media/$7\\\" class=\\\"pdf-shortcode-iframe\\\" type=\\\"application/pdf\\\"> <iframe class=\\\"pdf-shortcode-iframe\\\" src=\\\"https://docs.google.com/viewer? url=https://myurl.com/media/$3&embedded=true\"></iframe> </object>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}