#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(&)?((amp)|(zwnj));"
Local $sString = "remove '&zwnj;&#8203;' from messages" & @CRLF & _
"<these>should</also> be removed"
Local $sSubst = "\1(?(3)&|@)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)