import re
regex = re.compile(r"(&)?((amp)|(zwnj));")
test_str = ("remove '‌​' from messages\n"
"<these>should</also> be removed")
subst = "\\1(?(3)&|@)"
result = regex.sub(subst, test_str)
if result:
print(result)