re = /(&)?((amp)|(zwnj));/
str = 'remove '‌​' from messages
<these>should</also> be removed'
subst = '\\1(?(3)&|@)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result