using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(&)?((amp)|(zwnj));";
string substitution = @"\1(?(3)&|@)";
string input = @"remove '‌​' from messages
<these>should</also> be removed";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}