use strict;
my $str = 'remove '‌​' from messages
<these>should</also> be removed';
my $regex = qr/(&)?((amp)|(zwnj));/p;
my $subst = '\\1(?(3)&|@)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";