import Foundation
let pattern = #"(&)?((amp)|(zwnj));"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
remove '‌​' from messages
<these>should</also> be removed
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1(?(3)&|@)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)