#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)node\.([[:alnum:]]*?)\."
Local $sString = "// Print `Hello, world!` every one second." & @CRLF & _
"if (Global.currentFrame % Global.targetFPS == 0) {" & @CRLF & _
" print(node.sensorlink.encoder1Position) //.encoder1Position);" & @CRLF & _
" // print(node.sensorlink.encoder1Position) //.encoder1Position);" & @CRLF & _
" "print(node.sensorlink.encoder1Position) //.encoder1Position);"" & @CRLF & _
" 'print(node.sensorlink.encoder1Position) //.encoder1Position);'" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// Node("sensorlink").encoder2PositionRelative" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")