const regex = /node\.([[:alnum:]]*?)\./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('node\\.([[:alnum:]]*?)\\.', 'gm')
const str = `// Print \`Hello, world!\` every one second.
if (Global.currentFrame % Global.targetFPS == 0) {
print(node.sensorlink.encoder1Position) //.encoder1Position);
// print(node.sensorlink.encoder1Position) //.encoder1Position);
"print(node.sensorlink.encoder1Position) //.encoder1Position);"
'print(node.sensorlink.encoder1Position) //.encoder1Position);'
}
// Node("sensorlink").encoder2PositionRelative
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}