using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node\.([[:alnum:]]*?)\.";
string input = @"// Print `Hello, world!` every one second.
if (Global.currentFrame % Global.targetFPS == 0) {
print(node.sensorlink.encoder1Position) //.encoder1Position);
// print(node.sensorlink.encoder1Position) //.encoder1Position);
""print(node.sensorlink.encoder1Position) //.encoder1Position);""
'print(node.sensorlink.encoder1Position) //.encoder1Position);'
}
// Node(""sensorlink"").encoder2PositionRelative
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}