re = /node\.([[:alnum:]]*?)\./m
str = '// Print `Hello, world!` every one second.
if (Global.currentFrame % Global.targetFPS == 0) {
print(node.sensorlink.encoder1Position) //.encoder1Position);
// print(node.sensorlink.encoder1Position) //.encoder1Position);
"print(node.sensorlink.encoder1Position) //.encoder1Position);"
\'print(node.sensorlink.encoder1Position) //.encoder1Position);\'
}
// Node("sensorlink").encoder2PositionRelative
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end