import re
regex = re.compile(r"node\.([[:alnum:]]*?)\.", flags=re.MULTILINE)
test_str = ("// Print `Hello, world!` every one second.\n"
"if (Global.currentFrame % Global.targetFPS == 0) {\n"
" print(node.sensorlink.encoder1Position) //.encoder1Position);\n"
" // print(node.sensorlink.encoder1Position) //.encoder1Position);\n"
" \"print(node.sensorlink.encoder1Position) //.encoder1Position);\"\n"
" 'print(node.sensorlink.encoder1Position) //.encoder1Position);'\n"
"}\n\n"
"// Node(\"sensorlink\").encoder2PositionRelative\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")