package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(2[1-9]|[3-9]\d|1\d\d)|([0-9]|1[0-9]|20)`)
var str = `7 10 17 18 19 20 21 22 23 24 30 40 100 120`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}