// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(2[1-9]|[3-9]\d|1\d\d)|([0-9]|1[0-9]|20)").unwrap();
let string = "7 10 17 18 19 20 21 22 23 24 30 40 100 120";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}