const regex = /(2[1-9]|[3-9]\d|1\d\d)|([0-9]|1[0-9]|20)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(2[1-9]|[3-9]\\d|1\\d\\d)|([0-9]|1[0-9]|20)', 'gm')
const str = `7 10 17 18 19 20 21 22 23 24 30 40 100 120`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}