use strict;
my $str = '7 10 17 18 19 20 21 22 23 24 30 40 100 120';
my $regex = qr/(2[1-9]|[3-9]\d|1\d\d)|([0-9]|1[0-9]|20)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}