import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G|^)\\d";
final String string = "aaaaaaaaaa 123\n"
+ "5aaaaaaaaa 45\n"
+ "4707aaaaaa\n"
+ "aaaaaaaaaa\n"
+ "923aaaaaaa";
final String subst = "X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}