$re = '/(?:\G|^)\d/m';
$str = 'aaaaaaaaaa 123
5aaaaaaaaa 45
4707aaaaaa
aaaaaaaaaa
923aaaaaaa';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;