using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(January|February|March|April|May|June|July|August|September|October|November|December|[\d ]+)|.";
string substitution = @"$1";
string input = @"1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101
(c. 1929)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}