$re = '/(January|February|March|April|May|June|July|August|September|October|November|December|[\d ]+)|./';
$str = '1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101
(c. 1929)';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;