import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(January|February|March|April|May|June|July|August|September|October|November|December|[\\d ]+)|.";
final String string = "1 circa February 1950\n"
+ " testing July August Septiembre Octubre 7 8 9 10 10b ... 101\n"
+ "(c. 1929)";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}