const regex = /(January|February|March|April|May|June|July|August|September|October|November|December|[\d ]+)|./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(January|February|March|April|May|June|July|August|September|October|November|December|[\\d ]+)|.', 'g')
const str = `1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101
(c. 1929)`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);