using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Movie\s*(.*?)\s*(S\d\d\s*E\d\d|$)";
string input = @"Movie TOTO S09 E22 2022 Copyright
Movie TOTO TITI TATA S09 E22 2022 Copyright
Movie TOTO 2022 Copyright";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}