package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Movie\s*(.*?)\s*(S\d\d\s*E\d\d|$)`)
var str = `Movie TOTO S09 E22 2022 Copyright
Movie TOTO TITI TATA S09 E22 2022 Copyright
Movie TOTO 2022 Copyright`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}