// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Movie\s*(.*?)\s*(S\d\d\s*E\d\d|$)").unwrap();
let string = "Movie TOTO S09 E22 2022 Copyright
Movie TOTO TITI TATA S09 E22 2022 Copyright
Movie TOTO 2022 Copyright";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}