import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Movie\\s*(.*?)\\s*(S\\d\\d\\s*E\\d\\d|$)";
final String string = "Movie TOTO S09 E22 2022 Copyright\n"
+ "Movie TOTO TITI TATA S09 E22 2022 Copyright\n"
+ "Movie TOTO 2022 Copyright";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}