const regex = /Movie\s*(.*?)\s*(S\d\d\s*E\d\d|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Movie\\s*(.*?)\\s*(S\\d\\d\\s*E\\d\\d|$)', 'gm')
const str = `Movie TOTO S09 E22 2022 Copyright
Movie TOTO TITI TATA S09 E22 2022 Copyright
Movie TOTO 2022 Copyright`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}