$re = '/Movie\s*(.*?)\s*(S\d\d\s*E\d\d|$)/m';
$str = 'Movie TOTO S09 E22 2022 Copyright
Movie TOTO TITI TATA S09 E22 2022 Copyright
Movie TOTO 2022 Copyright';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);