# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ (?=[a-z]+=)/&/gm;t' <<< "act=abc aaa=zzz bbb zzz cc=ddd dd=aa bb cc"