use strict;
my $str = 'act=abc aaa=zzz bbb zzz cc=ddd dd=aa bb cc';
my $regex = qr/ (?=[a-z]+=)/mp;
my $subst = '&';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";