const regex = / (?=[a-z]+=)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?=[a-z]+=)', 'gm')
const str = `act=abc aaa=zzz bbb zzz cc=ddd dd=aa bb cc`;
const subst = `&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);