import re
regex = re.compile(r" (?=[a-z]+=)", flags=re.MULTILINE)
test_str = "act=abc aaa=zzz bbb zzz cc=ddd dd=aa bb cc"
subst = "&"
result = regex.sub(subst, test_str)
if result:
print(result)