$re = '/ (?=[a-z]+=)/m';
$str = 'act=abc aaa=zzz bbb zzz cc=ddd dd=aa bb cc';
$subst = "&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;