using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?=[a-z]+=)";
string substitution = @"&";
string input = @"act=abc aaa=zzz bbb zzz cc=ddd dd=aa bb cc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}