using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(File ""[^""]+?"", line \d+, characters \d+-\d+):\n(Error|Warning): ([^]+?\.)\n\n";
string input = @"File ""./Solution.v"", line 3, characters 2-13:
Error: In environment
n : nat
Unable to unify ""n + 0"" with ""n"".
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}